Alesis Micron XYZ Encoders/Knobs Suddenly started acting weird

hey folks, first time poster here, looking for a bit of advice on my Alesis Micron which has been fine other than a dirty volume pot which should get replaced. things have been working fine besides that though i don’t play it every day, but just yesterday after a session i noticed the XYZ encoders/knobs (i read these were actually dual wiper pots but i don’t know of any pot that spins forever is both directions) started going all haywire on me, and not behaving properly. it would make performing using those knobs impossible.

so, i got the service manual and ran through the diagnostics and although it passed most of the other tests it could not get through the encoder tests at all - weirdly it frequently claimed it was receiving data from the expression pedal so it would interfere with the encoder data, but the encoder itself seemed strange too. maybe all the pots suddenly need cleaning when they were working fine 48 hours ago? also the light under the pitch bend wheel seems to react to the encoders as well, albeit intermittently. all the buttons on the right work fine, and the pitch wheel as well. i’m not 100% sure about the rotary encoder switch on the far right, but it seems fine as far as i can tell. i did later test the expression pedal input by plugging one in and that stopped the interference but the encoders are still not working smoothly. a hard reset (holding down -Oct, Programs and Setups buttons on powerup) did not change the behavior.

any advice? there are a couple of used ones i could buy if it seems like this would be an expensive fix. even a chassis for cheap - it has the XYZ knobs and clear rotary encoder and case but not the analog out main board. i’m purchasing some Radio Shack cleaner - i have flux remover but that didn’t seem to do anything to clean the pots. i suspect something more substantial is happening but not sure. anyway any feedback appreciated!

EDIT/Update - since the XYZ knobs (and i confirmed they are indeed dual wiper knobs and not encoders) and Expression pedal input seem to be involved in posting spurious data values, i took a look at the schematic for the center panel board. it appears that signal values for the XYZ knobs PLUS the expression panel go through a TI CD4051 analog multiplexer. so if for some reason that chip broke a solder trace or is intermittent or failing this might explain why all four inputs are suddenly not working properly when things were fine a few days ago. at this point i’m inclined to get a center panel board replacement and try it out and see. maybe the 4051 is socketed and i can just replace it.


okay update to this post. i replaced the center board with a better one and the XYZ knobs worked great, but then i tried to update the banks via sysex and i appear to have royally bricked it. the screen now says ‘Alesis Micron’ and nothing else, and i can’t seem to reset it or do anything. i think it’s stuck in a sysex update and either hasn’t received enough data or perhaps the right data. has anyone ever had this happen? any possible solutions?