Ensoniq ESQ-1 selected parameter value glitching/jumping around

Hello! So my Ensoniq ESQ-1 just started to have this behavior where the parameter that is currently selected starts to jump around and glitch in value as if I were moving the data slider randomly, but on it’s own. Any ideas to what may have possessed my beloved ESQ-1? FWIW this occurs without any MIDI jacks, footpedals or anything connected.

Is the slider a pot or encoder?

If a pot try cleaning with Deoxit.

It’s a potentiometer. I’ll try deoxit first. I was reading another person on gearspace that had what seemed like a similar problem and ended up fixing the problem by recapping the power supply.

Update: Tried Deoxit, didn’t help. I also just tried replacing the slider with a 5K linear potentiometer temporarily and it’s still giving me the same behavior. Any other ideas? Any help is greatly appreciated!

Update Update: The connector(s) that goes from the control panel to voice board somehow became partially unseated and everything is behaving just fine again. So if it’s of any help to someone who encounters this problem check your connections!


Thanks for following up with the solution, it’s very helpful.