Ensoniq SQ-80 Strange Problems - Please Help

Hey Guys I have an SQ-80 that started exhibiting some strange behavior. Hoping you can help.

I turned it on one day and noticed that I got a ‘low batttery’ warning and the data slider wasn’t working. I replaced the slider and at first, nothing worked. I noticed then that the pitch wheel was only bending down, and the mod wheel wasn’t working at all. Then after a soft-reset the slider started working, but not going through the full range of values. After two more soft resets the data slider, pitch, and mod wheels were all seemed to be working OK.

The battery tested at 2.8v, but I was still getting that low battery warning so I installed a new battery.

Now, back to the same problem - and this time I can’t get anything working again. Data slider doesn’t work, pitch and mod wheels do not work at all. Every time I turn the synth on i get the ‘low battery’ message, even with the new battery (that tested fine at 3.1v) I’ve tried resetting the machine several times with Record + Top Left Button. I even tried the hard reset, jumping R1 to the lower left pin on UC50. No luck.

No values change in the analog test screen (Record + Compare) when I move the pitch and mod wheels. All values, including ‘BAT’ are 255.

All filter values are ‘000’ in the filter tuning screen (Record + Filter)

I tried reseating all the connectors. Even cleaned all the contacts with de-oxit. Still no luck.

Also tried popping in my old Eproms (I’d upgraded to 1.8) - same issues.

Stranger yet - everything else on the machine works. I can load patches from disk, all the keys and buttons work, aftertouch is working, screen is a-ok, and I’m getting sound out of the outputs.

Looking through the service manual, the issues seem to point to a problem with the power supply or main board. There’s a guide for trouble shooting the PSU, but I wouldn’t know where to start diagnosing the main board.

No idea where to go from here. Any assistance would be greatly appreciated!


The power supply is pretty easy to test - but it doesn’t sound like it is faulty. If all those things are working (display, etc.) then they are getting the correct power.

I’m guessing there is a main board problem somewhere, but not sure what it might be. Somewhere else on this forum is a thread about an ESQ-1 showing filter values of all zeros, and I’m pretty sure he has an issue with the Q-chip or microprocessor. I think you are having a similar problem (or perhaps with the digital circuitry associated with those chips).

Thanks for the reply Sam! I found that thread:

The issues do sound similar. It does make sense it’s a main board issue, as everything else seems to be working OK.

Any chance you have a functional main board in stock? That would be the most straightforward way to fix it I guess.


Did you contact Rainer Buchty (www.buchty.net / rainer@buchty.net). I think there is noone - beside former Ensoniq employees - who knows the SQ-80 better.


I haven’t yet, but I got my diagnostics info from his online copy of the SQ-80 service manual. Also saw he has a few IC’s in stock on his website.

I may do some poking around on the mainboard this evening and shoot him an email.


Shot an email off to Rainer last night and I had a reply this morning:

From Rainer:

I think the culprit is the 4051 voltage mux that routes the input
voltage to the ADC. Might also be the signal conditioner sitting behind,
in worst case the DOC itself (which also houses the A/D converter).

There might also be a chance that the 4051 addressing fails so that it
doesn’t get activated or only routes the unconnected input.
PSU issues can be ruled out, otherwise the sound would be not working
or sounding distorted

After reading that I started poking around in the Q-chip/4051 area of the main board (to the right, under the key bed). I pressed gently on the main board in that area and the SQ-80 came back to life, however the controllers wouldn’t hit their max values. Some further wiggling around and everything started working correctly, but after a while the issues would return. Another press and it was working again…

…sounds like this may be a bad connection/cold solder joint or broken trace on the main board right around the DOC / 4051 chips.

This might involve pulling the main board and giving it a close examination from the back side, I’ll keep this thread updated with what I find.


1 Like

A most excellent update!

Great news - my SQ-80 is back!

Turned out to be a bad solder joint on capacitor C72, which looks like it’s part of the circuit for the signal conditioner Rainer had mentioned in his email.

After sorting that out, everything is working 100%. It looks like the synth had liquid spilled on it at some point, as the cardboard underneath the main board was stained and warped. There was a bit of corrosion on the solder joint in question. A few pics here:

Replaced the left output jack while I was in there, too. :slight_smile:

  • Chris