Ensoniq TS10 system error 139 and 17

Hello all :slight_smile:I’m here because I would like to now if someone allready got this error on a TS10?
I’ve bought a faulty unit. after fault analysis the VFD screen was broken.
I’ve just replaced the screen and now I get “system error 139 reinitialize”, the unit reboot and get system error 17 and reboot in loop with the same error code
any advice about such error? the battery, fuses and PSU voltages are OK.

Found an old link to TS12 error messages (http://www.ts12.de/ts12-fehler.html) however partly in German - I can translate though:

139 unused vector
Interrupted devices provide a vector number, but that vector register was never initialized.

Can’t find error 17 through -

Did you replace the VFD with an original or an equivalent?

Error 139 indicates to me the the CPU has received a interrupt service request from a device but has no entry on what to do with it hence trap to error 139. Could be the VFD … ?

found more details - according to below … may be an idea for a full reset:

Hello wernersaurus and thanks for your answer.
I’ve found these infos too in the service manual and tried them all without success
I’ve even tested all the clock source with my scope and they are ok but without shcematic it will be a pain to go further.
i’ve found one picture of the schematic but it’s not really easy to read it.
repairing the andromeda A6 was easy compared to this one without schematics ^ ^…
I will try to scope the board with my thermal camera to “see” which component is not “working” copared to others.
but at first look the 68000 seems to work (slightly warm) and the OTTO stay cold -> perhaps the origin of code 17. in this case if it’s the OTTO chip, it will not be easy to repair unfortunately
but I will check the OTTO chip supply to be sure. No power to a chip will cause the data lines to stay at low level and can cause continuous unexpected interrupts.