Ensoniq VFX SD (SD1-32) aftertouch always on?


I have a strange problem with a VFX/SD that has been upgraded to an SD1-32 (ROM version 4.10). I bought it used and quite cheap too. It’s mostly working fine except that the aftertouch (both channel and poly) always rises to maximum shortly after pressing any key (provided pressure is activated in the patch). Velocity works normally though. When sending MIDI to the synth it also functions as expected.

Another SD1 owner posted a similar issue on two different forums a few years ago, but sadly both threads are dead ends.

At first I thought it might just be dirt, but the problem persisted after a thorough cleaning (it was quite full of dust and dead silverfish bugs).

The connector between the coil boards had already been replaced with a wire, continuity checks out fine.

I tried both a soft and a hard reset as described in the service manual, made no difference. I checked if the ferrite bead is clear from the mainboard and the flat cable is folded around the gate array, as described in Service Bulletin #12.

Since velocity does work normally and I don’t have any of the usual bad connector misbehaviour (random notes etc), I assume it has to be something else. Next suspect was the KPC board (rev D, version 2.33). Especially because for some unknown reason this board had been modified as follows:

-the trace between pin 1 and 2 of U4 (74HC00AN) was cut
-there was a wire running from pin 2 of U4 to pin 30 of U1 (MC68HC11A1P)
-there was a wire running from pin 3 of U4 to pin pin 6 of U3 (S38BC01PS01)
-the trace between pin 30 of U1 and pin 6 of U3 was cut

As far as I could figure out this means the clock line between the processor and the KPC chip was rerouted through a (normally unused NAND gate). I really wonder why ??? Anyway, I undid the modification but again it made no difference whatsoever.

I then tried booting up the synth with a “naked” keybed (all keys removed from the assembly). I had expected some kind of error but strangely enough, keyboard calibration passed without any problem. Maybe this is just how OS 4.10 deals with the keyboard? Or yet another clue to suspect the KPC?

When booting without the keyboard attached I get the message “KEYBOARD IS NOT ATTACHED” and booting freezes.

When booting with ONLY the KPC attached, I get “KEYBOARD CALIBRATION FAILED” but I do get the option to ignore and continue. Does that mean it could be something in the coil boards after all?

Is there anything else I can check before replacing the KPC board? There’s one up for sale in France (I live in the Netherlands) but before I spend any money on that while keeping my fingers crossed it will solve the problem, I’d like to make sure if the the issue is really with the KPC.

The main reason I’d like to fix and hold on to this synth is the poly pressure keyboard, so even though it works fine as a MIDI sound source that kind of defeats its purpose for me…

greetings from Holland,

Just a quick follow up: I exchanged the KPC rom, but it makes no difference unfortunately. Keyboard still generates full aftertouch on any keypress.

Any ideas except replacing the whole KPC board?


When you say that it has been upgraded to an SD1-32 (ROM version 4.10), what was done? Was this just a ROM upgrade? Or was the main board replaced?

I assume the main board was replaced. The unit came with the original ROMs but one of the newer ROMs is of a different size.

To clarify: the main board has the newer ROMs installed, but the previous owner kept the original ROMs. But since one of the newer ROMs has a few more legs then the old ROMs, I assume that the entire main board was replaced.

you obviously know what you doing in regards to checking of the circuit board as well as the rom configurations to trouble shoot the problem. I own sd-1 brought used from guitar center not as dirty as yours no bugs however half a container of Clorox wipes and a can of deoxit 8 and a can of air spray no strange problems as yours i haven’t done the rom upgrade. so it is good to hear of other people experience with this upgrade i haven’t purchased this upgrade. did you get the service manual for further trouble shooting. my keyboard was kept in a wet environment that would explain the rust and corrosion on the exterior screws probably a basement or garage it should be criminal to treat a keyboard like this. there are other ensoniq forums that have good advice even though there are a lot of people here who are ensoniq genius. that machine you have there is an excellent keyboard see what these other guys have to say. good luck

I asked about the upgrade since you said that it was upgraded to an SD-1 32. When I upgraded my SD-1 to ROM v4.10, I didn’t notice any errors but I believe that to get to 32 voice you must replace the main board. I didn’t see any differences in the ROMs labelled for use in the standard or 32 voice keyboards when I did a byte for byte comparison.

The two ROMs are different sizes. That is normal. One ROM holds half of the firmware, while the other holds the other half of the firmware plus samples used to recreate the sound of the grand piano.

When he upgraded it to 4.10, did he give you a copy of the updated OS disk?

I bought the unit from the previous owners’ widow, she didn’t know much about it but I did get some floppydisks as well. Do you think reinstalling the OS could solve the problem?

That’s what I was thinking, but I’m not so sure. You most likely had to do that when you performed the hard reset. I don’t know if you can load the wrong level, though, and I have no idea what would happen.

This might be one for TheSoniq. Never used him, myself, but he might have some ideas

The hard reset didn’t involve any floppydisks, it just reinstalled stuff from ROM. But now I’m wondering if that only resets the memory, or both memory and OS. I’ll have a look at the floppies when I get back to the studio, it sure is worth a try. I still suspect the KPC chip though, because that’s the one translating the raw data from the keyboard to velocity and aftertouch. And aftertouch does work properly when playing the synth from external MIDI, so I figured there’s nothing wrong on the receiving end of that data. But who knows… fingers crossed!

The manual recommends re-initializing as the first step in troubleshooting. That erases all memory and forces the CPU to execute initialization code from the ROMs. It then says that you need to re-load the sequencer OS from the disc. That is the only reference I see to the disc.

Nothing is said about the keyboard itself. I assume that the main cpu instructs the keyboard to reboot. The fact that the display works is a good indication that the communication paths are working. All communication is serial, so it is telling the main board that the aftertouch has been activated.

What about removing all of the keys but for one or a few? Does it still react when you press one? Just wondering if one of the keys is somehow acting up and affecting them all.

I have already completely disassembled the keybed to clean and investigate. Unfortunately the behaviour is the same with just one key.

I think it’s the keybed. Something has to be upsetting those coils to cause this. Since you can’t narrow it down to one key, I’d say it’s something common to all of them - an oscillator?

Maybe you’ve got a cold solder joint somewhere. I’d try re-flowing all solder connections around the micro.