ESQ-1 Display Issue

#1

Hey All, I’ve got an esq-1 plastic model that I bought with the display giving garbled characters. Because I couldn’t find any spare boards for sale I went to Rainer Buchty and bought his replacement Display process unit and installed it. The screen worked great for a day! I powered it on and it worked. Powered the unit off. Then a minute later powered it back on and the display was dark and the buttons didn’t work. The keyboard was still making sound though. I’ve gone through all the connector cables and they look good. All the voltages to all the ICs on the display board look right according to the schematic. I’m not sure what else to look at. The weird thing is that I powered it on the other day and the display worked again while I was using the board. Powered it off and back on and now it’s gone. Seems like it could be a bad connection or something but I’m not sure what else to look at.

#2

Even though the ICs are getting good voltage, is the display itself getting the correct voltage? I think the power supply should be sending a much higher voltage to the display, so this could be a power supply issue. I would first make sure all power supply fuses are good, and that the power supply board is putting out the correct voltage for the display.

Garbled characters on the display typically mean that the display is working, but it is not communicating properly with the main board. This can be a cable/connector issue, or it can mean that the main board has a problem. But since you are getting sound out, I’m betting the main board is fine.

#3

Hey Sam, so, after double checking every lead from the 6500 process to their next component in line I can validate that there is a good connection between each. I did discover that the buttons and data slider do work but I have to hold a button down for about a second before a change takes place. The fuses are all good and I’m measuring the appropriate voltage going to all ICs on the. The vbb is 56v.

#4

Just to clarify, there are no garbled characters after installing Rainers 65003 chip. It work fine after the initial install displaying perfectly all the menu items. Then after shutting down and turning back on it was blank with the abnormal button behavior. Also, if I unplug the data cable to the mail board the display doesn’t go into self check mode.

#5

Hello:

I also had an ESQ1 with a blank display. I found that C3 on the display board had gone totally open. It feeds a 50/60 Hz timing signal to the display processor. Also had another keyboard with a VFD that was blank. Heating up the display pins and applying some fresh solder brought the display back to life.
Hope this helps.

#6

Thanks PPD! I’ll take a look at the caps.

#7

So the caps look ok. One thing I’ve noticed is that if I disconnect the display board from the main board I don’t get any sound when playing the keys. Is this normal? I thought I read somewhere that the esq-1 should make sound even if the display board is disconnected…

#8

Hey csonics;
Just checked my ESQ-1 with the 4 pin data cable disconnected from the main board. There is no sound output so that is normal behavior.
Pat