Korg Polysix notes change not working

Hello experts!
I have been working for a while now on my Polysix. I installed the Kiwisix upgrade (w/ power supply) and was not able to properly tune it.
I found out it was probably due to the optocoupler which I replaced with a VTL5C9 and it made things worse :confused: :

  • All keys play the same note - so I have a mono-note polysix which does not pitch
  • Pitch wheel has no effect
  • Effects and voices are fine
  • VR2 has no effect on tune
  • pin7 of IC18 measures 14V (should be between -3 and -6 from what I’ve read)
  • The filter keyboard tracking still works, which means the keys are still correctly recognised

What I have tried:

  • I put the original optocoupler in place and same problem. So… I think I might have broken something in the procedure.
  • Tried two other VTL5C9s (from 2 different suppliers)
  • install the original optocoupler back
  • I replaced Q12 - still no change.

I have made extensive research but could not find any thread talking about this issue.
Anyone has an idea of the potential reason why it behaves like that? I am thinking about ordering all replacement ICs.