Moog Matriach Aftertouch

I just picked up a Moog Matriarch and the aftertouch is not working properly. I got a constant 5v from the aftertouch output without any keys pressed, so I tried through another midi controller and was able to get the 0-5v that I expect. I checked the resistance in the aftertouch strip, and I get around 125 ohms when nothing is pressed but can get it to drop to 85 ohms with a lot of key pressure. As I understand, I should get a very high resistance with nothing pressed. So, it is acting as if there is pressure when there is not.

I contacted Moog support, and they sent me the calibration procedure. After running that I can get a little movement in the output voltage. I get 4.5v with nothing pressed and can get it up to like 4.9v with a lot of pressure.

Do I need to replace the aftertouch strip, or is there something else I should check? I did pull off some keys to see if there was anything odd going on around the strip, but I didn’t see anything obvious wrong.

An update on this, in case anyone has the same questions:

I replaced the aftertouch strip with one I purchased from Syntaur from another keyboard. I had to also carefully swap the foam/felt pad, since the replacement had much thicker foam that prevented the full articulation of the keys. I also had to cut the strip down, since it was meant for a larger keyboard. Everything is working fine after replacement.

I don’t know what happened to the original aftertouch strip. These strips tend to be pretty robust. It wasn’t working when I got the synth used, so I have no idea if it ever worked.

1 Like