Ensoniq Ts10 keyboard not responding

Hi all - I’m getting the dreaded ‘keyboard is not responding’ error on my TS10 after months of seamless use.whats the solutions

Thanks in advance


Mine had the same error. came to be the coil board chips were not receiving the reset signal from the 555 monostable circuit at startup. The 3.3 uF capacitor next to the 555 ( connected to pin 6 i think) was bad. Once replaced, the keyboard worked.

Not saying this is for sure your issue but hopefully the information can help you troubleshooting it.

not working bro i trie


What is the value of the big cap ?

black capacitor is 100uf 16v

Oh nooo, that is too high. Have something around 3.3 - 4.7 uF.

I recommend you verifying the soldering on c30. Doesn’t look good. Use some flux and wick to clean the board and re-solder. Use flux (tiny amount) when soldering. This will make your joints much cleaner and easier to test.

You need to clean the board with rubbing alcohol every time after useing the flux. Just gentle rubbing nothing crazy.

If you have an oscilloscope, see if it possible for you to test the output of the 555 when you power up the keyboard. You should see one pulse shortly after powering up.

Let us know how it goes. Fingers crossed.