Microkorg Edit select knob skipping parameters

Greetings all,

I purchased a used Microkorg locally and have been enjoying it for about 2 years now.

However, I’ve just run across a problem.

When using the edit select knob to change parameter values, there seems to be a “dead” spot when I try to change the “amp eg” values. When the select knob is on the amp eg portion, the top knobs control the previous “amp” values, and when cycling back to amp, it still works as intended. Hopefully this all makes sense. Basically the ADSR section of my microkorg is inaccessible.

Has anyone ever come across anything like this? I’ve taken it apart to the PCB and sprayed some deoxit into the pot from the side and worked it in pretty well, but to no improvement. Is the next step replacing the pot?


Two things i can think of. Could be dirty selector contacts or broken solder. I suggest cleaning the selector with contact cleaner or any proper electronics cleaner and re applying solder.

Thanks for the response. Sorry for my ignorance, but how would I go about cleaning the selector? I saturated the potentiometer pretty good with Deoxit and then worked the knob back and forth a couple dozen times. I’ve heard of people cleaning the pot with q-tips. I figure I could tear it down again and try that, I honestly didn’t think to check for broken solder. The fact the knob still works, just not in that detent led me to believe that this was due to some dust or something causing poor conductivity for that knob position.

Sounds like you’ve already done the cleaning part.

One more thing, that dead spot, does it have the same clicking sound like the others ? Just trying to exclude the possibility for any broken pieces inside the switch.

All of the knobs click and feel like they should before it started acting up. I’ve come across a new problem though. There’s 2nd knob under my problem knob that controls different parameters and that same position on that knob is also unresponsive. In this case, its 3 o’ clock for both knobs. I’m not an electronics whiz at all, but I feel like that would be more than a coincidence. Is that a problem on the PCB?

I see, sounds like the common scanning line for these two knobs. Might not be a difficult issue to resolve but since you’ve mentioned you’re unfamiliar with electronics then i’m afraid there is no much to do.

Not sure if it’s worth to repair it. Just buy a second used one if really need that function, OR, use the editor software to get by.


Would this be a simple solder job? I feel like I could manage that. Luckily, like you mentioned that the editing software would be able to be used as a work around for this.

Could be but i can’t tell, it is not that simple. 1st you need to utilize the schematics and 2nd different signals and components must be checked in order to identify the cause.

Again i suggest you to utilize the editor until you find one with a good price.

Gotcha. Thank you for your help!