Oberheim Matrix 1000 Corrupt ROM Patches


#1

I have an Oberheim Matrix 1000 that had a pretty loud power supply hum issue. I hired a local electronics shop to install a new power supply as detailed here: https://www.gearslutz.com/board/electronic-music-instruments-and-electronic-music-production/1006972-oberheim-matrix-1000-psu-fix-guide.html#post11047551

New power supply is installed, working and nice and quiet. The power hum problem is gone.

Since getting the unit back with the new power supply none of the 800 ROM patches work or sound correctly. It is like they have become corrupted in some way. Some of them don’t make sound at all. Some do, but sound very odd. Some play out of tune.

I am able to load patches in the 200 RAM slots without a problem. These sounds all work perfectly. The unit plays like normal and sounds great if I am using any of the loaded 200 RAM slots.

I read a forum post online where someone was having a similar issue as I have described. Someone recommended updating the firmware chip thinking this might solve the issue. I did purchase a 1.16 firmware upgrade EPROM and installed. Unfortunately this did not change the issue/problem with the ROM patches. They still sound strange and corrupt.

Does anyone know where the 800 ROM patches are stored? If they were on the firmware EPROM I replaced I think the issue would have been solved.

I would like to get the ROM patches restored to normal if possible. Thanks in advance for your help.


#2

The firmware and 800 rom patches are stored in separate eproms. The firmware eprom is the one beside the 68B09 CPU and is a 27256 eprom. The 800 rom patches is a 27512 eprom installed beside the firmware eprom.

Since the only thing that changed was the power supply, i would start there first.
If you have a meter check to ensure all the voltages from the power supply are within spec. The most critical one is the +5V which powers the digital circuitry. It should be within 5% ( +4.75V to +5.25V).

Another possibility is that the pins on the socket and/or eprom have tarnished over time and not providing a good/reliable connection. Gently removing and reseating the eprom may clear the tarnish enough to provide a good connection.


#3

We have the program data EPROM chip available here:

If reseating yours does not help, I would try replacing this chip.


#4

Thanks for the help! When I tried re-seating the EPROM at U803 I determined that one of the pins was broken. I am glad Syntaur has the replacement chip available! I just placed my order!


#5

Sam, I replaced the ROM chip today and it fixed the problem! It is great having the 800 ROM sounds back again. Thanks again for the help! It is much appreciated!


#6

Excellent news - thanks!