Roland D20 Help Req

Hello everyone.
Hope you are all well.

I recently acquired a very tired Roland D20 synth. I’ve replaced all the buttons as most weren’t working. Stripped and cleaned the key bed.
All good.
The floppy drive wasn’t working. I took it apart and the drive belt had disintegrated into a gooey mess around the drive motor. I freed everything up, ordered and fitted a new belt.
When I tried the drive it still wouldn’t work. I tried it a couple of times to see if it would spring into life but it continued making unhappy sounds.
Then the display glitched and I got an internal battery error showing. I replaced the battery and since then the synth won’t boot.
It is just stuck in a boot loop with the display saying Roland D20 Linear Arithmetic Synth.
I saw a post on the web that said a dodgy drive can damage one of the boards.
Does anybody have any idea what component could have failed to prevent the synth from booting ?

Take care people.

Many digital keyboards require performing a factory reset after replacing the memory battery. Also isn’t the floppy drive a standard type that could be entirely replaced? PC type? Worth a try.

Thanks for the reply.
Sadly the floppy drive is a Roland specific drive. The synth doesn’t need the drive to work, it is only used to store songs created on the onboard sequencer. I just like to get everything working when doing a refurb.
Since I originally posted I have been looking on the web and someone mentioned doing a factory reset without the battery and then putting it back in so you could be right.
I will give it a try.

Thanks again.

Take care,

Then it would seem you’ll have to contact a Roland US authorized dealer to order their drive, if Syntaur doesn’t have salvaged floppy drives from Roland units.

I think that would cost more than I paid for the synth. :laughing:

If I can’t fix it I’m happy to just not use it. I bought the synth mainly as a controller for my D-05 Boutique as it matches the design.

Take care,

1 Like

I hope you haven’t flipped the floppy drive cable when mingling. My W-30 is stuck at the startup also. I bought it as and couldn’t get it to work.

Try to see if it is possible to hard reset it.

It might be the floppy drive controller chip. Just a guess.

Thanks for the heads up. It gives me a place to start if I need to get the silly scope out.
I didn’t mix the cables. It was trying to work but was not sounding very happy.
I’ve been doing loads of work on a Korg Wavestation (new screen, new buttons, 5 new keys and upgraded to an EX) last few days so the D20 will probably be this weekend when I have a peep at it.

Take care,

When I said not use it I meant the floppy drive, not the synth. :grinning:

Hi All.

Update on this. Finally got to spend a little time on it.
Reseated the processor on the main board.
Tried a hard reset with the battery removed.
Still getting the same fault. I’m starting to think there might be something in the saw somewhere that said a bad floppy drive can pull down a component that prevents the synth from booting.
There is a replacement CPU board on eBay I may take a punt on. The floppy plugs directly into the CPU board so it is a good shot I guess.

Take care,