Roland Jx3p sequencer not advancing

Hi, my jx3p sequencer won’t advance steps. When I select write and play notes on my keyboard the sequencer doesn’t not advance to step 2,3,4. It just combines all the notes in 1 step. It will advance with the step or rest button. Seems weird, has anyone experienced this? It’s been documented on the net but never a solution. Logic chip failure? Any help would be greatly appreciated!

Did it work already?
If no: are you sure you are releasing the keys in between the steps carefully?

It is important to know that it works like that:

  • Press Seq Write
  • Press Note1
  • Release Note1 -> First Step is written
  • Press Note2
  • Release Note2 -> Second Step is written
  • Press Note3
  • Press Note4
  • Release Note3 (note4 is still pressed)
  • Press Note5
  • Release Note4 (note5 is still pressed)
  • Release Note5 -> Third step is written.
  • Press Run
    => a three step sequence is written with single notes on step one and two and a three-note-chord on step three.

A step will be written only if the last key is released. To enter a chord it is not(!) necessary to play all notes of the chord at the same time unless you whatchout that always one of the keys stays pressed.

Thanks for the response! I have had this synth for almost a decade and the sequencer did work exactly as you stated. However now the sequencer acts as though the key press never terminates or when I hit a key and release the key it stays latched for whatever reason. It’s weird and makes me think something in the logic is stuck. I have the unit open now and I see a lot of 4051 multiplexers and know that those can have issues. Just wondering if anyone else has seen this issue before. I have seen others have the same issue but no documentation of a resolution.

sorry for the delayed response.
The 4051’s are not involved here.

Basically this reads like a key contact is stuck, which is mechanically quite unlikely. Also I’d assume that you should hear a sound as soon as the synth is switched on.

I think the sequencer advances on the same system status on which the MIDI-command “all notes off” (CC 123) is sent. May be you can check in a MIDI-monitor or sequencer program, whether the JX does send this CC value. It should be sent at least in normal mode (not recording a sequence).

Could this somehow be linked to the fact that this jx will not switch out of Omni mode? It’s so annoying. I’ve tried all the sequences and it just won’t behave as it should. I’ve gone as far as getting an anatek channel filter to get it to pay nice with my rig

No it is not related. I had around 15 JX3Ps on my bench including an assumed Beta-Model, and none of them had problems with switching from Omnimode to Polymode-Channel-1.

DId you check, whether CC123 is sent?

Huh, I haven’t checked the midi monitor yet. During troubleshooting I started to notice that the power supply was intermittently dropping voltage on one of the 9v taps, then it dropped out totally so I’m waiting on a replacement transformer. I went ahead and re capped the psu, replaced the 7805 regulator and switched out the bridge rectifiers too. I’ll report back once this synth is putting out the right voltages so I can reconnect the voice and control boards.

That is not the transformer but the rectifier. I’ve never seen a transformer breaking on the secondary side. The primary side would make all voltages fail.

So the ±15 are fine look good and steady. The 5v is completely dead. When I meter the orange taps according to the schematics both should read 9v and I’m getting a 9v on one and 0v on the other. The transformer did get really hot so I suspected it was a overheat circuit inside the transformer that tripped. I replaced the bridge rectifiers first thing because they are cheap and a new transformer is not. Thoughts? I’ve had this synth a for over 20 years and bought it used for 75 bucks so I’m not super hurt about putting a little money back into it.

I don’t believe that the 5V is dead, because really nothing would work if the 5V were not ok. No led would work, not note would sound, nothing.

I think you are measuring wrong.

Well when I originally posted this it was working fine. I had it on while playing in the studio and when I came back into the room all leds were unresponsive and scrabbled the case above the transformer was very hot and I turned it off put it on my bench and started metering the psu. The 7805 output was 3v or below so knowing that cpu chips need 5v that would explain the scrabbled leds and a non functional synth. I unplugged the psu from the rest of the synth so I wouldn’t fry anything down stream and looked around on the net. Everyone seems to point to the bridge rectifiers so I replaced them but ultimately the orange 9v taps weren’t both putting out 9v at the solder tabs coming into the psu. Everything points to the transformer pooping out on me. Comically my Juno60s transformer died on me about 2 years ago, so if my timeline is correct they are about right on time with each other. I popped in a replacement and everything worked again. IDK if that helps your logic but in my experience transformers do go bad and this one seems to have stopped working so I’ve ordered one, it’s on the way and it will verify if this was the issue. Then I would love to figure out this seq. issue. I don’t really use the function at all as I seq. With my mpc but I’m trying to get all my gear to work :100: and not have some low hanging issues. Prolly a unrealistic goal bit hey, I’m trying.

New transformer, and I’m back in business! I’ll be plugging the unit into a midi monitor soon if midi cc 123 isn’t present what does that indicate?