Syntaur Supersoniq CDROM Bad Disk Directory

Hey, I just received the Supersoniq CDROM sample set from Syntaur for my EPS16+. When I try to change the storage device, I get BAD DISK DIRECTORY error every time. The disc is recognized by my ChickenSys Translator program when I put it in my desktop and the drive at least appears to be recognized as it does the light blink when powering up the EPS16+ during the looking for SCSI device phase. If no disk is in the drive, I get the “Disk is not Ready” message. I’ve tried some disk images that I got from a guy of Ensoniq floppies burned to CDROMs that do the exact same thing.

I’ve tried switching the SCSI device ID, which only seems to work for the CDROM on 4 and 6. Both still give the Bad Disk Directory message though.

I’m using a SCSI cable that works fine with my SCSI2SD. I have a termination plug on. Tried switching those to no avail.

Is this an issue with the disk itself, the drive (Apple 600e external CDROM), or something else? EPROM? Power supply?

Ultimately, I can just dump it all on SD cards for the SCSI2SD drive I suppose, but the disc images I have are a pain to transfer over like that. And I’ve got about 16 of them.


There are so many variables with a SCSI setup like this, especially with the EPS-16 Plus, which has a very rudimentary SCSI implementation. So for starters, do you have any Ensoniq-format CD-ROMs that read and load correctly from the SCSI drive directly into the EPS-16 Plus?

The SCSI drive should be set to ID 4 for the Ensoniq samplers - otherwise it won’t work as intended.

Thanks for the reply!

No discs work in it. I either get the “Bad Disk Directory” message (most of the time) or “Disk not Responding” (occasionally).

It’s set on 4 currently. I tried every one from 0-7 (excepting the 3 of course) and only 4 and 6 return anything. I noted in the Sample Magic that 4 is proper, so that’s what I’ve been using the last couple times.

Is it important to have active or passive termination on the SCSI? Currently it’s passive.

I’m not sure the 600e drive is compatible with the EPS-16 Plus. In a quick online search, I saw that someone was selling one as compatible with the ASR-10, but the ASR has a much better SCSI implementation than the EPS-16 (which was released around the same time that SCSI was born). The Sample Magic book lists compatible drives for the EPS-16, and the 600e is not on the list. I am guessing that this is the problem. The EPS-16 is VERY picky about which drives it is happy with.

Ok. Seems to make the most sense considering everything.

I’ll look for one listed. The 600 was the only one I could find that matched anything on the Sample Magic list and Chicken Systems’ with an external case. And the market for external cases is pretty dodgy from what I’ve looked at so I was hesitant to pick up an internal.

Found an Apple 300e Plus on eBay and gave it a shot just now. Works! Definitely can confirm that 600e does not work with an EPS16+.

Man, copying instruments from SCSI CD-Rom is clunky…