Yamaha DX7IIFD sustaining problem

A friend of mine got this DX7IIFD basically for free because it wasnt working correctly and asked me to have a go at repairing it. I’ve fixed a number of issues with the board and it’s much improved though I’m stumped on one issue. All but a couple of the voice/patches will sustain indefinitely as if the sustain pedal is being held down. I’ve tried transferring new voices via sysex a few times and it’s the same result.
The couple of voices that don’t have this problem will respond to sustain pedal messages as intended but I’ve only found 3-4 voices that respond normally.

Another thing that I noticed is that occasionally a voice will have several operators that don’t seem to do anything, for instance an algorithm that has all six operators in use will have no affect when turning off 3-4 of the operators.

I’ve performed the internal test procedure and everything passes except for the disk drive which is also having issues.

The power supply is within spec. The firmware rom is socketed and there are two different firmware versions but neither of them change the issue.

Hoping someone has experienced the same issue or might be able to point me at a way of narrowing down the problem that I haven’t considered.

Could be a memory corruption issue. Is there a way to re-initialize nvram? On some synths you can unplug the ram chips and insert them into aluminum foil or conductive foam to clear them out.

Oh that’s a good thought. I’ll check it out. Unfortunately nothing is socketed, though the board is fairly forgiving to the desoldering process. Would disconnecting the whole main board and grounding it out work just as well?

Good question, might be worth a shot but I would disconnect any battery on the PCB first.

1 Like

So I removed the board, took out the battery and layed copper sheeting across the board where the various static ram chips are. It did initialize the board (though the same happens when just removing the battery) but unfortunately the sustaining continues even after retransferring known good sysex files and comparing those against my volca FM. Also, the EG data shows up quite a bit differently between the two.

Another thing I noticed. I’m able to save to a cartridge even with it saying “Verify error!” I then put the dx into crt memory protect mode and flip the memory protect switch on the cartridge. If I leave the crt in when power cycling it acts as normal but if I power cycle it without the crt and then again put it in. The dx will say “Cartridge Format err!” and won’t access the crt until I reformat it again.

Not sure if this also points towards a ram issue. It would seem that if data was actually stored on the cartridge it wouldn’t matter if the internal ram was having problems so perhaps there is an issue with data flow elsewhere. Not sure what role the psram has in read/write functions. Perhaps the crt data is stored temporarily in psram to

I’ve never tried using my scope to analyze digital data. Perhaps this will be one of those projects that will push me into new skill land.

Sounds like there is a short to ground somewhere in the memory logic side, perhaps an inadvertent solder blob or a shorted film or tantalum cap. Tantalum caps are a curse in synthesizers. I haven’t looked at the schematics recently but there are usually film and tantalum caps in the timing circuits A/D conversion and the clock.

From memory, another issue is this model had a board outsourced with lots of surface mount capacitors. Those are past end of life now. The issue was between 1978 and 1988 to meet production many Japanese production shops increased the temperature of the solder 10 degrees above what the caps could tolerate, which shortened their lifespan. This has been what’s causing the death of most Japanese products with SMD caps built in those years.

If you have SMD caps recheck for leaking, green corrosion on traces or fishy smells.

Well, I was a little busy and wasn’t able to get to this for a while. I’m still stumped however. This DX7IIFD doesn’t have any smd parts. I do notice a very faint but odd smell that I haven’t been able to locate. Would a picture of the circuit board be helpful?

Well that’s good news, if you can smell something you know its a failed part. A tantalum capacitor hopefully, but lets not hope for a FET transistor. Look for that failed part and also look around to see why it failed in the first place. If its just a tantalum capacitor, those fail at end of life. Just replace it with an electrolytic, and see if it fixes the issue.