Yamaha S30 - powers up but no sound

While using my Yamaha S30 the sound simply quit. The screen stays lit up and when I restart the synth it goes through the normal steps on the display. But there’s no sound at all. Is there an internal fuse that may have gone? I’m going to open it up later today to see if I can see anything but if anyone out there has had this happen and can let me know any possible solution I’d appreciate it.

Have you tried the headphone jack to check for sound?

I hadn’t tried that. I though of it last night and it was my first step when I started to work on the synth. Headphone jack worked but very scratchy. Some contact cleaner should resolve that. Knowing that I took apart the complete signal chain and reconnected everything. It worked a bit then quit again. Then I removed a number of items from the signal chain and it worked. Then I added things step by step… Ultimately it came down to a cable with an intermittent fault. That cable is now in the garbage and things appear to be good. Thanks for the suggestion.