YDP S54 usb to host dead

Hi all, it’s been a while since I last used the USB to host function on YDP S54.

cable’s been connected forever and when I tried plugging a Mac or an iPad or anything it seems the connector is dead.

Any ideas? is there a way to replace the connector? or test it?

Check the cable first…

I tried three different cables. Connector is a bit loose which is inexplicable because rarely touched.

I was wondering if messing with setuoe keys I might have disabled USB or something.

You could replace the USB jack on the DM board. Or the whole DM board
The jack is VAP29600 and about $5. It will obviously need to be soldered, so don’t damage the traces.
The whole DM is VAP27900. About $150.
Good luck!

Well … goes from the USB connector board more or less straight to the main CPU on the DM board. Hence, unless the USB connector on the USB board is somehow broken/corroded (corrosion can happen when plugged in for prolonged time as different metals do tend to chemically react) then there is not much more than the DM board itself (see pic)

Part number for the little USB board is: