Emu Emax 2 issues

I’ve owned this emax for about 25 years. Had to store it in a shed inside its hybrid case for a few years and the disk drive mechanism rusted out but the unit still worked. As of the last few years it still turns on and the screen lights up but nothing comes up on the screen. It does the initial “all lights” diagnostic and then gets stuck with the Stop and Record lights on. I tried resetting the unit holding the Stop and Record button while powering up but it doesnt change the condition. Opened up the unit and aside from the disk drive having corrosion in it the rest of the unit and boards look very clean. I inspected the PSU and a few of the caps look a bit bulged but not leaking from what I could see. I’m in Largo, Florida and up until recently there was a service center really close by but he’s retired. If I wouldve known I would have taken it there a few years back. Any help and suggestions on where to start would be greatly appreciated.

contact your local music stores to see if anyone local is available to service it.

if you caps are bulging, replace them, in fact just replace them period, if the unit is that old. Chances are its the caps. now sometimes if the cap fails it will also take out the voltage regulators and or the PS control module. If the screen doesn’t want to illuminate, but you can still see the print, electroluminescent panel is burnt out. you can get replacements on Alibaba or you can try ebay, there are people selling those units. Sometimes they are next to impossible to replace without changing the lcd part of the unit. Syntaur may have replacements for those.

But replace the caps first, and if it dosn’t get up to speed then take it in. Just remember electrolytic caps are polarized and must be replaced in the correct polarity.

Thanks, replaced the caps yesterday on the PSU to start and there’s no change. Unit powers up but gets stuck upon start up and doesnt show anything on the screen but it is lit so the backlight is working. I bought the smaller caps for the other two boards but havent installed yet, just trying to do this systematically in case I screw something up I can isolate it to a specific board. Ive read some issues are resolved by resetting the ICs but Im not sure which ones they are or in which board they are contained.

I decided to inspect the display connector on the board and noticed that many of the pin slots were missing the pin contacts inside the holes. They probably corroded away but I was still getting continuity from the solder points on the board and the outside of the connector. Since I had purchased an OLED screen anyway I decided to swap the screen and jump the pins to the connector points to ensure I had continuity and it worked. Upon turn on now I get “Emu Systems Inc, Checking Floppy!”
But Im not out of the water yet. Nothing happens when I insert the floppies with the operating system on them. Not sure if the disks are bad, (I have 3 with the operating system 2.14 on them) or if the drive itself is bad. The drive lights up and I hear it spinning but all I get is “Please Insert Disk!” on the screen. I’m betting the drive itself is bad as there was a disk stuck in it and it was pretty corroded so I had to take it apart to clean it and some little piece of something fell out of it. What options do I have at this point to see if it will load the OS and a sample? I do have a Gotek on my SQ80 that I can remove and install briefly but I have no way of transferring the disk image onto a thumb drive. Anyone have a link to the OS image I can download?

Second Update:
I decided to install my old SQ80 drive on the Emax to see if it would work, really not sure about compatibility but what the hell, and largely all the Emax 2 disks I have either show up as “Not Formatted”, “Disk Error” or “Read Error”. Only a few gave me a “Not an Emax 2 disk” message. But on one occasion I was able to load the OS and everything was working. I was able to access all the functions except being able to load a bank from disk. I attempted to format a disk and it gave me a disk error message. Once I turned it off and tried to reload the OS it has not let me since. Still not sure if it’s something with the drive or maybe my disks are so shot that it cant read them properly. Only one disk currently even attempts to load but the red leds and the screen shut off a few seconds in. The disk drive light remains on so I know there is still power and the unit isnt shutting down completely. Other than trying to find and testing a good known disk, Im at a loss right now…Any help would be appreciated.

Highly recommend you check out emxp.net

Thanks, much appreciated. I downloaded it and its pretty cool. Unfortunately I have no way currently of uploading an OS disk into the laptop and the emxp website has multiple OS files except for the Emax 2. Do you think one of the Emax Os image files would load on the 2?

IDK maybe find an E-Mu user forum or ask on modwiggler or gearspace. There used to be an E-Mu yahoo group but it shut down a while ago.

Third Update:
Decided to Swap out the drive with my Gotek after finding the OS file and a few bank files I needed. Took me a few hours of trial and error with the EMXP program but I finally got it to boot the OS and load banks. Everything works, ran the hidden special tests and they passed(except for the RS422 as I had nothing connected to it).
One minor issue…NO SOUND lol. Im hearing a loud pop on the headphone output when I first turn the unit on but nothing else. Nothing coming out and nothing coming in either. I tried feeding it a sound source through the sample in and nothing shows up on VU meter. There’s no sound coming out of the mains or subs either. I hooked up a midi to usb device and the keyboard is sending midi note on and off commands so at least I know that’s working. Other than pulling that board and replacing the caps on it Im not sure where to go after that other than making sure the ribbon cables have continuity from one side to the other but they look to be in good shape. I did test the PSU voltages and they tested within spec.

With the issues you had with the display, I’d be suspicious of the cable running to the analog jack board.

My next step would be grab the schematics and a scope and probe the signal path.

1 Like

I agree with using a scope. That’s the only way he’s going to see what’s happening here. Anything else is going to be trial-and-error

I’m trying to make some sense of the schematics now. It looks like there is a PCM56 IC for each channel, and each is connected to a separate pin going back to the CPU board. I haven’t found the IC that drives these circuits yet.

From looking at a picture of the analog/jack board, I see a number of the ICs could be socketed. Oxidization could have built up in any one of them, so reseating may help. A little bit of Deoxit wouldn’t hurt.

Checked continuity on the D2A ribbon and it passed. Checked voltages on it also to make sure it was getting to the output board. I checked voltage on the two Voltage Regulators and theyre showing .65 volts on the third leg from left to right. Nothing on the first and second(one is ground) which leads me to believe voltage isnt coming in to reduce it to 5 volts. Decided to replace the caps and it did not change the condition at all. I can read a schematic pretty ok but I dont own or have experience with a scope so at this point I either take the board in to have it checked or source a replacement board. All other functions on the unit are working now and verified that the keyboard was transmitting and receiving midi.

I think you’re getting close.

The schematics aren’t clear on the power supply - the power supply board is completely missing. I have found the regulators on the analog jack board, but nothing is detailed on the main board.

Let’s see if I can post the link here: https://drive.google.com/open?id=14sT9o-wmlTrosLFVLhZTSqHhpoeG319s

If that link fails, I found it in a thread on the eiiiforum.com regarding an Emax II memory problem, reply 29.

As near as I can figure, the power supply board supplies regulated voltages to the main board, and then these lines are passed to the other boards. The regulators on the analog jack board supply isolated +5v and -5v lines for the audio output.

My next step would be to check that relay. When you have a good +5v signal, a small circuit will energize the coil of the relay, which will connect the +10v and -12v from the main board to the analog jack board. Only then will you have voltage going into the 7805 and 7905. If that relay is stuck open, you won’t get anything working on the analog side

Thanks, I do have the schematic. On page 59 it mentions the PSU voltage ranges and mine is within spec. If you are referring to the Blue relay by the 40 pin connector it does have some brown stuff oozing from one of the corners, its hard like glue though so I dont know if thats normal or not. I do show continuity between pins 4,6, 11 and 13 and I dont think that should be like that. Maybe I’ll remove it and test it off the board to see if maybe there’s a short inside or if its on the board. The voltage regulators show ground on the input pins which is concerning.

I missed that page. Good catch!

Okay, they treat a switching power supply as a component that is not field repairable. That explains why I couldn’t find anything in the schematics. Also a mention that if the +5v is too low, the relay will chatter.

I think that reading ground on the input lines of the regulators is correct. The circuit is drawn in the off state and shows the 10v line being connected through a 10 ohm resistor to ground, bleeding the capacitors. You’re reading that resistor. When on, the 10 ohm resistor will be disconnected and the external 10v will be present.

I don’t follow your pin numbers 4, 6, 11, and 13. On my copy I see pins 1-8 on the relay. Regardless, that goo doesn’t sound normal. Is the case cracked? I’m thinking that the years in the shed were not kind to it, and the glue inside softened and expanded. That could have also expanded into the internal switch mechanism.

Sorry, I pulled up the data sheet for that relay and thats how the pins were labeled. On the Emax schematics they would be 4,3 and 5,6 I suppose. Voltage is getting to the relay and coming out of it but its grounding out. There shouldnt be any voltage between t he board ground and the chassis but there is lol Although Im not going to let this go I did order a “new” board today from Syntaur. I’ll keep working on it and keep it as a spare or at least for parts.

If you’re ever in the market this scope is super handy and in DVM mode is dead on with my Fluke.

Edit: this is not an affiliate link!

1 Like

That looks like a very nice scope… Most of the handheld scopes I’ve seen have had 2" displays which make it very hard to read. And 250MSa/s looks very impressive. Much better than my old palmscope. Being battery powered also means this would work great when you need an isolated scope.

I think I’ll save myself a little bit and pick up the 50MHz version to supplement my deskbound scope.

That relay sounds very strange. There should not be any continuity between those pins. That would describe voltage coming into the board and shorting out across the 10 ohm resistors. I think I’d pull it off the board and test it. Hopefully the relay presented enough resistance that the voltage dropped across the relay rather than anything else.

I’m not sure what’s going on with the ground. I see two separate grounds connecting to the board, but I haven’t seen where they connect to each other. It does sound like one of them has been allowed to float.