TS-10 Keyboard Calibration error

Hi All, so I’ve got a ts-10 that tries to calibrate the keyboard then give the error that the keyboard is not responding. I’ve tried replacing the jumper that connects the two coil boards under the keyboard and still get the same error. I’m not sure what to try next and can’t find a schematic for the ts-10 anywhere on the internets… Any suggestions on what I should try next?

Is the battery okay, they still have those in the TS-10?

Yes, is new and still pumping out a solid 3v.

Thanks,

It could well be a problem with one of the keys. The TS-10 keys have a thin metal plate at the bottom of each, and if that plate has become loose or broken off, the initial scan of the keyboard will fail. If you shake the TS around, do you hear anything rattling? If you run your hand down all the keys (pressing them as you swipe), do you hear anything rattle, or feel one that doesn’t go down all the way?

So I actually took off all the keys and inspected each one. They look ok. Would I be getting the keyboard not responding error if it’s a key induction issue?

Well, now it’s an electronic issue, and therefore a lot harder to diagnose. It could be an issue with the coil board(s), the main board, or perhaps the ribbon cable that connects them.

I’ve already replaced the ribbon cable that goes from the coil board to the main board with one from Syntaur :slight_smile: any thoughts on what to check on the coil board to validate its working right? I noticed a number of small variable resistors on it but I can’t find documentation on what they adjust

We have not found a good answer to how those trim pots should be adjusted - but we do know that if they are out of adjustment, it will cause a calibration error.

Hey Sam, thanks for the feedback. I’ve been looking for replacement coil boards, Syntaur appears to be out of them. I was able to find a pair of EPS-16 plus coil boards for sale on eBay. Any ideas if those might work? Thanks!

No, unfortunately those are different boards. The TS-10 and ASR-10 share the same boards, but no others will work.

Thanks for the clarification. I’ll keep looking.

I too have two ts-10’s with the same error.
Emma on the ensoniq forum said it was prob FETs on the coil board (keyboard).

anyway I now need to have four units fixed; friends have come out of the woodwork :slight_smile:

1 Like

Thanks griffenmastering! I’ll try replacing the fets and see where that gets me.

I acquired a TS-10 recently and got a very good price because it was doing the same thing - failing the keyboard calibration.

I fixed it but it was a rather difficult diagnosis and a VERY difficult and very intricate bit of soldering to fix it.

If you take the key coil board out of a TS or ASR you will see a dual coil configuration on the top and bottom of the pc board under each key. This is a really nice way of detecting velocity and pressure independently for each key. The way (I’m pretty sure) it works is that each resonant coil network is energized with a small AC signal whenever the keyboard is powered. Each key has a small metal plate on the bottom. As the key approaches the coils on its way down, it detunes this coil system and causes the current in the coils to drop. Using this info the TS can determine how close the key is to the pc board. The coils are probably sequenced really rapidly and tested on an individual basis many times a second. A second explanation would be that the system is measuring the inductive coupling between the coils with the metal plate acting as a transformer core. Considering the small mass of aluminum on the bottom of each key makes a lousy transformer core I think the resonant coil system is more likely.

In order to make sure this system is operating properly, the TS fires up each key’s coil system (probably in sequence) to make sure that a nominal current is being established with the keys all in the up position.

There are several conditions that can cause this calibration to fail.

  • One of the keys is held down
  • A metal plate fell off a key
  • There is a fault in one of the coils
  • Component failure in one or more of the coil circuits

In my case it was a coil that had failed. I determined this by “Ignoring” the keyboard calibration failure and noting that only one key was dead.

I removed the keys and started testing the coils below that key. There were two areas where the solder mask looked a little strange so I CAREFULLY scraped off the mask above those areas. The copper below them looked just fine but my meter showed a break in the copper at the bottom right 90 degree corner shown below.

So began the difficult task of trying to get solder to flow on traces the size of hairs. After almost an hour of trying to get a single fine strand of wire to jump the gap I actually got it to flow on both sides of the gap.

The fix is so embarrassingly ugly I assumed there was no way it could work. The trimmed ends just hover over the other traces so there is no shorting of any turns but it looks terrible. I have lots of experience with the soldering iron and can do a nice job at normal through-hole scales but this was extremely fine pitch work. I don’t however have a $1000 SMD soldering station and a Bausch & Lomb scope for fine pitch work. :slight_smile:

Anyhow, here is the nasty looking fix and indeed the TS-10 works perfectly. :slight_smile:

Only one photo per post for new users so here’s the fix.

I let the ends of the repair wire section hang beyond the solder points as it wasn’t causing a short with the masked traces below it and trying to cut that close to the tiny solder blobs might stress them to the point of breaking.

No, that’s not a giant novelty pencil. :slight_smile:

I went digging for some more info on these coil boards. I found a great reference. You can find basic schematics and additional details here.

http://www.tauntek.com/ASR10.htm

It turns out I was close to understanding how these things work. They are, I gather, resonant circuits that are allowed to freely oscillate and so the metal on the bottom of the key changes the natural frequency of the circuit so the oscillation frequency changes. This frequency change is what is detected by the keyboard controller.

The schematics even list some adjustment parameters for the to adjustment pots on the coil boards. Sam and the Syntaur techs may find that useful.

1 Like