Yet another DX7 No Sound post


I have a DX7 I bought earlier in the year that I have yet to get making sound. I recently acquired another one that the owner said also didn’t make sound. That one needed a new battery and a bit of love getting the sounds loaded back on.

So, I’ve used the good one, to test components on my other one and here’s what I know:

  • It’s NOT the power supply. If I drop the bad main board in the good DX7 I get no sound. If I drop the power board from the bad DX7 into the good one, it works fine
  • It’s not the battery, as that’s also new
  • I’ve replaced all the canister style capacitors and also IC42 (don’t ask me why that IC, I can’t remember)
  • I bypassed and then put back the relay, that didn’t make any difference
  • Literally everything else works. The self tests work, the cartridge can load and save sounds. Sounds show on the screen, the buttons work, I can play on the keyboard and midi works, aftertouch works, the wheels work. Just no sound from the main board.

At this point I’m at a loss. I do have a multi-meter, and I recently bought a small, digital oscilloscope off Amazon but I need to learn how to even use the thing. I probably have no business even working on this, but I want to learn more and eventually understand how to fix any of these that come my way (I have a CZ101 someone gave me for FREE that has power issues, but that’s for another post).

I do understand the basics of testing for voltages across the board in places, and I’m not afraid to solder (though I still feel like I suck at it).

So here I am, trying to decipher all the other DX7 posts and figure out where the issue is on this thing. Any help from those much more experienced at this would be much appreciated.


Sounds like you need to probe the audio path with an oscilloscope. Before the output of the synth the signal travels through a handful of opamps and other components. Before that is the D/A converter which converts the digital information into an analog audio signal.

You can start by probing pin 6 of IC56 and see if you have any signal there. If not then you will have to work backwards to IC53, IC52, etc. towards the D/A converter. If there is signal at IC56 then you need to follow it forwards through the audio path and see where it stops. Check inputs and outputs of ICs and check their datasheets for ones that aren’t opamps to make sure they’re functioning properly.

1 Like

Thank you, this is a great help to get me moving!

If I were you I would think about professional audio repair. I’m not sure where you’re located but I can refer you to 3 places for repair. You should contact them all to see if they can give you an estimate. Armen’s Music in Manhattan, N.Y. Next: Rogue Music in Manhattan, N.Y. Next: Sweetwater in Indiana. Anyone of these places can fix your issus with the DX7

Can you navigate through all the menus? Are the patch names there and look sensible? If a DX7 has lost its patches the names will be garbled and it will make no sound but work otherwise. The patches need to be reloaded via sysex and some of the global parameters like the portamento reset to zero. If the patch names are all there and you can navigate normally i would be looking at the output stage with a scope and you need the schematics! Is it the brown one with green membrane buttons (Mk 1) or black with push buttons (Mk 2) ?

It’s a brown MK I. As I mentioned, I have two here. One works, the other everything but sound. All the menus work, the sound names, once loaded, are fine. Cartridge works, self tests work. I’ve replaced most of the capacitors, so that’s not it. I’m working on probing now, but still not exactly sure as to what readings I need. I’m slowly looking through the schematics and reading to try to learn how to do this-because I want to be able to do it on other gear too. As far as sending it somewhere-this is a beat up unit that I was just hoping to turn into a project. I don’t want to spend money having someone else fix it, I want to learn myself. If I destroy it, I’ll just part out the rest (2 working DC boards, working key bed, etc). It’s definitely the main board (swapped into a working unit and produced no sound), so It’s got to be the output stage at this point.

Yeah reread the post again and yeah it’s not the easy stuff. I’ve worked on a couple of those that either had sound issues sorted by a sysex reload or booting issues where the problem was in the digital section. First i would check whether the DAC is receiving data. The chip is a BA9221 it has 12 data input lines that come from one of the two large FM chips. If you see nothing there then I don’t like your chances getting one of those is gonna be difficult! If there’s activity on all 12 input lines then your problem is the DAC or something afterwards. Do you hear hiss or anything int the headphones? If you don’t then it might be something simple. You definitely need a scope or audio probe, schematics and patience!

There was hiss, though I haven’t plugged headphones into it in a while, so I’m going to do that today and double check again. Thanks!

Okay, learning how to use my scope today lol. Checking the good DX7, IC 42/BA9221 puts out all sorts of patterns on the scope when I play notes. The same thing on the bad DX7 and I get nothing. Now, the BA9221 on the bad DX is a new chip, I replaced it several months ago after reading some things online (I think I ordered 2 off eBay). It’s possible either I made it worse or more likely, the issues is before IC42. If I probe the dots above IC 36 that are just there on the board, they’re dead on the bad DX. Also, if I probe pin 32 on IC 36, I get signal if I play notes on the good DX, and nothing on the bad one.

Did you replace the BA9221 in an attempt to repair this problem before? Assuming yes. You’ve got me wondering when you say that this might have made it worse.

Looking at the schematic, lines DA1-DA12 are routed to the BA9221. If you’re not seeing any activity on those lines, then IC36 isn’t working. That doesn’t necessarily mean that the YM21280 is bad: It could just be that a control line or supply voltage isn’t making it to the chip.

Everything around IC36 should be a digital signal: either 0 or 5v. I would expect to see a high frequency square wave on most pins. Nothing you do to the chip should cause a sound unless you have a bad connection.

IC36 is also directly related to IC29. You might also check for activity on its pins.

I did not read the full thread, so sorry if I am repeating something with my may be stupid question:
Did you check the socket of the volume pedal? As far as I know this is not a control input but a true insert for the audio signal. If the switching contact of the socket is broken or corroded, nothing will come out.

1 Like

When I say “made it worse” I mean screwed up installing BA9221, but when I think about the fact that there’s nothing coming out of IC36, then I realize it’s farther back than that. I’ll keep at it.

On a side note, as part of my learning process I break things. I’m learning the hard way to BE CAREFUL around electronics. My good DX7 now has weirdly digital distorted output, as if every patch is a hard, digital synth lead. I replaced BA9221 with a new chip and that wasn’t it, so I have replacements for IC40 and IC41 on order from Digi-key. It’s entirely my fault, and yes, I feel terrible about it, so yes, I hear everyone’s warnings to let someone else work on my stuff-but I really DO want to learn how to do this going forward. This was a hard lesson learned to BE CAREFUL when mucking about inside a keyboard with a probe. Hopefully I didn’t blow something I can’t replace, but we’ll see. For now I’m setting this aside so I don’t break something else.

Thanks for all your help!

Okay, stop.

I think you’re on the right track, but you need to think things through before deciding on your next step.

First, check the volume pedal socket as fanwander asked. It might turn out to be a simple solution after all. I haven’t traced it through, but that sounds possible if volume is controlled by the cpu.

That BA9221 you removed: Do you still have it? The shotgun approach of replacing chips seems tempting, but you need to be careful that you don’t replace a good part with one that was defective - and you run that risk when you buy through eBay. It’s quite possible that those lines could be held low by the BA9221 you installed.

Now I’m worried about the ‘good’ dx7. Hopefully a reset cures it? I can’t imagine how looking at pin activity could cause something like that. But there seems to be little need to be poking around in it. Without pinpointing the actual fault, you could be compounding the problem.

I have stopped for now. I know it’s not the volume plug because putting the bad board in the good DX7 also gave no sound. (this was before I messed up the good DX7). I did keep the BA9221 in foam in a foil bag, so I’m good on that. It came out pretty cleanly. I read somewhere else that someone had the same distorted issue with a DX7 and it turned out to be IC40 that wasn’t regulating things properly and a replacement fixed it. But yes, I did something to the good one so that it sounds like a digital harsh synth lead 100% of the time now. You can hear the original sound back there a bit, but on top of it is the nasty buzzy synth. Replacing the BA9221 on the good DX didn’t change a thing. And yes, I know I run the risk of compounding things, so I’ve just set them aside for now till I can wrap my head around everything. I am glad about one thing, I only paid $75 for the good DX7, so if I’ve ruined it, I can part the thing out and make back more than I spent. There’s a tiny hole in the membrane and otherwise it’s in great shape. I still feel horrible, so I hope I can fix it because it seems like such a waste, but at least it wasn’t a $350 investment. Thanks!

$75? That’s a fantastic deal!

You had me worried. I didn’t want to be giving advice if it leads to a second broken synth. But it does sound like you’ve at least narrowed it down.

okay, I’m doing a bit more probing in the DX that doesn’t make sound. Turns out that I get a strong signal on the scope out of nearly all the chips until I plug in either headphone or output. Meaning the second there’s something connected that requires amplified sound, the signal drops. If I had to guess, it maybe means something isn’t proving enough voltage and the output jacks drain it too much when plugged in? Not sure, but at least it’s a bit more of a clue as to what’s going on.

That’s interesting…

That’s my thinking as well. If we’re overloading the power supply, the supply voltages could fall below operational threshold for the digital circuitry. Unfortunately, the amplifier sections run off of the 15v supply lines, and the 5v and 15v supplies are on different windings. Where are you grounding your scope? (There are separate ground lines for each supply that may, or may not, be connected.)

Perhaps we’re just losing the 15v supplies? That would take out the analog section.

Have you measured the supply lines on the main board - not at the power supply - with and without the load?

Note: I’m theorizing a drop in supply voltage on the main board, possibly over a poor connection. Alternative is the final stage of amplification before hitting the external connector

Something you may want to check is the relay contacts on RY1.
High resistance on the contacts will reduce the signal to the headphones
and output jacks.


Good news on one front. I replaced IC 40 on the good DX7 and it’s back in business. It did reset a bunch of things for some reason, like portamento was on and some sounds only work when you push into the aftertouch. I figured out the portamento issue and am now looking into the weird aftertouch issue.

For now I’m still holding on the bad DX for a bit, but I do plan to use the good one to CAREFULLY compare signals and voltages with the bad one to see if I can trace the issue.

Well, that’s good to hear.

I’d love to know how IC40 got wiped out. Shorted a pin?